AnsweredAssumed Answered

BBPOS Device Not Configured Correctly?

Question asked by pyates@paysimple.com on Jan 6, 2021

Hi, 

we recently received multiple BBPOS devices that are throwing an error when trying to connect.

BBDeviceOTAResult: Failed, responseMessage: Terminal is not registered in TMS - Failed: Terminal cannot be found

2021-01-06 14:45:06.456161-0700 SDKTestApp[28323:18121541] (+[VPDError makeErrorWithDescription:description:])

 

Here is the device info:

2021-01-06 14:56:12.572891-0700 SDKTestApp[28358:18123994] BBDeviceOTAController - onReturnDeviceInfo - deviceInfoDict: {

    bID = CHB202022006617;

    batteryLevel = "4.096";

    batteryPercentage = 97;

    bootloaderVersion = "5.00.16.22";

    deviceSettingVersion = "BBZZ_Generic_v25";

    emvKsn = 629949010000BB800002;

    firmwareVersion = "1.00.03.43";

    formatID = 60;

    hardwareVersion = "1.0.5";

    isCharging = 0;

    isSupportedNfc = 1;

    isSupportedTrack1 = 1;

    isSupportedTrack2 = 1;

    isSupportedTrack3 = 0;

    isUsbConnected = 0;

    macKsn = 88888800007871600003;

    pinKsn = 88888800007871000006;

    productID = 4348423230;

    serialNumber = CHB202022006617;

    terminalSettingVersion = "BBZZ_Generic_v25";

    trackKsn = 629949010000BBA00001;

    uid = 240056000E504D3256333220;

    vendorID = 42425A5A;

}

 

 

Here is the device info for an older device that does connect correctly.

2021-01-06 15:00:58.838473-0700 SDKTestApp[28400:18128117] <BBDeviceController: 0x283f8f1a0> - onReturnDeviceInfo - deviceInfo: {

    bID = CHB204839001901;

    batteryLevel = "3.829";

    batteryPercentage = 56;

    bootloaderVersion = "5.00.16.22";

    deviceSettingVersion = "ANVB_Worldpay_v40";

    emvKsn = 62994901000023E00152;

    firmwareVersion = "1.00.03.37";

    formatID = 60;

    hardwareVersion = "1.0.4";

    isCharging = 0;

    isSupportedNfc = 1;

    isSupportedTrack1 = 1;

    isSupportedTrack2 = 1;

    isSupportedTrack3 = 0;

    isUsbConnected = 0;

    macKsn = 88888800000930400003;

    pinKsn = 8888880000092FE00006;

    productID = 4348423230;

    serialNumber = CHB204839001901;

    terminalSettingVersion = "ANVB_Worldpay_v40";

    trackKsn = 62994901000024000199;

    uid = 4A004B000150483553363420;

    vendorID = 414E5642;

}

 

Are the failing devices just not configured correctly to be registered with WorldPay? Is there anything I can do from my end to correct this?

 

Outcomes