Chris Jennings

A new Ingenico RBA version could impact your business

Blog Post created by Chris Jennings on Feb 20, 2018

Ingenico, a major manufacturer of U.S. EMV peripheral hardware, has made improvements to their previously released Retail Base Application (RBA) in their Telium 2 line of devices. This new RBA version is 21.02. Vantiv Integrated Payments, now Worldpay and Datacap System's dsiEMVUS and dsiPDCX solutions have adopted Ingenico's latest device application, RBA v21.02. This updated RBA is for the Telium 2 line of Ingenico devices (iSC 250/480, iPP320/350, iUC 285, iWL 258, and iCMP).

 

The RBA is the internal programing of the PIN pad and enables advanced functionality and communication to Worldpay. If your POS is programmatically confirming the RBA version, this could impact your customers very soon.

 

Summary

    • Programmatic RBA Checks within the POS application can create unable to process scenarios for merchants ordering new equipment or updating to a newer RBA version in the field.

 

    • The current RBA version 18.04 will be phased out and will no longer be available for new equipment orders or replacements for Datacap solutions on MercuryPay.

 

    • RBA 21.02 provides advanced functionality to the device and is currently the latest version adopted by Vantiv Integrated Payments,  now Worldpay with Datacap dsiEMVUS and dsiPDCX.

 

    • Worldpay recommends new equipment orders and in-field replacements migrate to this new RBA version.

What’s the impact of a programmatic RBA check?

Although this practice is not common, the result can directly impact the point-of-sale application to not support a new Ingenico device or a recently updated in-field device. Thus, rendering a merchant POS application unable-to-process payment transactions. Solutions that support an RBA check will need to make modifications to their existing code in order to support any new device deployment. Acceptable changes may include, but are not limited to:

 

      • Programmatically confirm an RBA version but do not require support for specific versions
      • Remove all code that programmatically confirms / checks RBA versions, and implement a manual process to verify the RBA version during a device startup.

 

Why is it important to adopt new RBA versions?

As way to simplify PIN pad deployments for both partners and merchants, Worldpay will adopt RBA 21.02, helping to minimize mistakes during device deployments. Within Datacap’s NETePay™ and client architecture, this updated RBA is considered backwards compatible. EMV Card Verification Methods (CVMs) and supported transactions can be configured to meet merchant business needs.

 

Additionally, this RBA version supports the acceptance of EMV PIN Debit using the Ingenico Telium 2 series. POS applications that have not implemented a RBA check, adopting RBA 21.02 is considered a drop in replacement for previous RBA versions. There are however some check points to consider:

 

      • If your system is upgrading to EMV Debit using the Ingenico series, this RBA is required as are the latest NETePay and dsiEMVUS client controls.
      • A Datacap engineered Field Loader is available for in field updates of iSC 250 devices.
      • If your system is not upgrading to support EMV Debit, using RBA 21.02 will have no impact to your current card acceptance experience as long as your system does not run a RBA version check.

Resellers:

If you have questions about the compatibility of your application with this updated RBA 21.02 version, your POS developer should be able to confirm if they have implemented a RBA check and if you can support this RBA in Ingenico devices.

 

Developers:

If you have concerns or questions about adopting Ingenico's RBA 21.02 and for additional features this may offer your reseller and merchants, please contact your Worldpay Implementations Consultant.

Outcomes